HDOJ 3466 Proud Merchants(01背包)

Proud Merchants


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 3588    Accepted Submission(s): 1497


Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?

 

Input
There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

 

Output
For each test case, output one integer, indicating maximum value iSea could get.

 

Sample Input
   
   
   
   
2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
 

Sample Output
   
   
   
   
5 11
 

按照能取得最大利益值排序,即q-p,然后就是01背包了

ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define max(a,b) a>b?a:b
#define min(a,b) a>b?b:a
#define MAXN 10010
#define INF 0xfffffff
using namespace std;
struct s
{
	int p,q,v;
}a[MAXN];
int dp[MAXN];
bool cmp(s a,s b)
{
	return a.q-a.p<b.q-b.p;
}
int main()
{
	int n,M;
	int i,j;
	while(scanf("%d%d",&n,&M)!=EOF)
	{
		for(i=0;i<n;i++)
		{
			scanf("%d%d%d",&a[i].p,&a[i].q,&a[i].v);
		}
		sort(a,a+n,cmp);
		memset(dp,0,sizeof(dp));
		for(i=0;i<n;i++)
		{
			for(j=M;j>=a[i].p;j--)
			{
				if(j>=a[i].q)
				dp[j]=max(dp[j],dp[j-a[i].p]+a[i].v);
			}
		}
		printf("%d\n",dp[M]);
	}
	return 0;
}


你可能感兴趣的:(HDOJ 3466 Proud Merchants(01背包))