Bone Collector
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 44702 Accepted Submission(s): 18620
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2
31).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2602
题目大意:有n个不同骨头,每块占用一定空间以及具有一定的价值,给定一个容量,求最多能装进的骨头的价值是多少.
解题思路:01背包。
动态转移方程:dp[i][j]=max(dp[i][j],dp[i+1][j-volume[i]]+value[i]);
d[i][j]代表在容量为j的情况下,不取i所能获得的最大价值。
dp[i+1][j-volume[i]]+value[i]代表在容量为j的情况下,取i所获得的最大价值。
#include"iostream"
#include"cstdio"
using namespace std;
int value[1005];
int volume[1005];
int dp[1005][1005];
int max(int a,int b)
{
return a>b?a:b;
}
int main()
{
int T;
scanf("%d",&T);
while(T--){
int n,v;
scanf("%d%d",&n,&v);
for(int i=0;i<=n+1;i++)
for(int j=0;j<=v;j++)
dp[i][j]=0;
for(int i=1;i<=n;i++){
scanf("%d",&value[i]);
}
for(int i=1;i<=n;i++){
scanf("%d",&volume[i]);
}
for(int i=n;i>=1;i--){
for(int j=0;j<=v;j++){
dp[i][j]=(i==n?0:dp[i+1][j]);
if(j>=volume[i])
dp[i][j]=max(dp[i][j],dp[i+1][j-volume[i]]+value[i]);
}
}
printf("%d\n",dp[1][v]);
}
return 0;
}