HDU 5477 A Sweet Journey(亚洲区水题)

Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice)
HDU 5477 A Sweet Journey(亚洲区水题)_第1张图片

Input
In the first line there is an integer t ( 1t50 ), indicating the number of test cases.
For each test case:
The first line contains four integers, n, A, B, L.
Next n lines, each line contains two integers: Li,Ri , which represents the interval [Li,Ri] is swamp.
1n100,1L105,1A10,1B101Li<RiL .
Make sure intervals are not overlapped which means Ri<Li+1 for each i ( 1i<n ).
Others are all flats except the swamps.

Output
For each text case:
Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning.

Sample Input
1
2 2 2 5
1 2
3 4

Sample Output
Case #1: 0

本题的大致题意为:一个人想去旅游,问他一开始最小需要的体力是多少。有两种地形,沼泽和平原,如果是沼泽的话,每米消耗A的体力,在平原每米恢复B的体力。要注意的一点是在这个过程中这个人的最小体力值为0,不可以小于0;利用这个条件求出在开始时具有的最小体力值。
本题个人感觉其实并不算太难,应该可以算上一道模拟题,为什么呢,,只要你读懂题之后,这道题就换成了最小值更新的问题,所以呢,,还是好好锻炼自己的思维吧。
下面附上AC代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;

int main()
{
    int t;
    int iCase=0;
    scanf("%d",&t);
    while(t--)
    {
        iCase++;
        int x,y;
        int flag=0;
        int n,a,b,l;
        int sum=0;
        int minn=1000000;
        scanf("%d%d%d%d",&n,&a,&b,&l);
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&x,&y);
            sum=sum+(x-flag)*b;
            sum=sum-(y-x)*a;
            minn=min(minn,sum);
            flag=y;
        }
        if(minn>=0)
        {
            printf("Case #%d: 0\n",iCase);
        }
        else
        {
            printf("Case #%d: %d\n",iCase,-minn);
        }
    }
    return 0;
}

你可能感兴趣的:(HDU)