HDU 1023 Train Problem II (打表求解卡特兰数)

HDU 1023 Train Problem Ⅱ:http://acm.hdu.edu.cn/showproblem.php?pid=1023

题面:

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7629    Accepted Submission(s): 4110


Problem Description
As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.
 

Input
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.
 

Output
For each test case, you should output how many ways that all the trains can get out of the railway.
 

Sample Input
   
   
   
   
1 2 3 10
 

Sample Output
   
   
   
   
1 2 5 16796
Hint
The result will be very large, so you may not process it by 32-bit integers.

题目大意及分析:

由于此题为非降路径问题,且观察样例,即要计算卡特兰数,由于数据比较大,所以要利用打表的方法。

注意此题所给提示为32位int不能存下,但是64位longlong也不能存下,大数打表还是比较可靠的。

代码实现://该代码算是卡特兰数打表的模板了

#include <iostream>
#include <cstdio>

using namespace std;

int a[105][100];
void Catal() //卡特兰数打表
{
    int i,j,yu,len;
    a[2][0]=1;
    a[2][1]=2;
    a[1][0]=1;
    a[1][1]=1;
    len=1;
    for(i=3;i<101;i++)
    {
        yu=0;
        for(j=1;j<=len;j++)
        {
            int t=(a[i-1][j])*(4*i-2)+yu;
            yu=t/10;
            a[i][j]=t%10;
        }
        while(yu)
        {
            a[i][++len]=yu%10;
            yu/=10;
        }
        for(j=len;j>=1;j--)
        {
            int t=a[i][j]+yu*10;
            a[i][j]=t/(i+1);
            yu=t%(i+1);
        }
        while(!a[i][len])
        {
            len--;
        }
        a[i][0]=len;
    }
}

int main()
{
    Catal();
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=a[n][0];i>0;i--)
        {
            printf("%d",a[n][i]);
        }
        printf("\n");
    }
    return 0;
}


你可能感兴趣的:(卡特兰数,大数打表)