【POJ 1742】Coins

Coins

Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 30413 Accepted: 10335
Description

People in Silverland use coins.They have coins of value A1,A2,A3…An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.
Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.
Output

For each test case output the answer on a single line.
Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
Sample Output

8
4
Source

LouTiancheng@POJ

队列优化的多重背包~

我们知道暴力的求解多重背包问题是 O(nms) 的,显然不能通过此题。

我们需要在 O(1) 时间内求出 f[i][j]

(以下 w[i] 表示重量, v[i] 表示价值)
假设当前计算到第 i 个,我们对于 modw[i] 相同的 j 同时处理,就可以使用队列优化了~

假设 j=w[i]k+b ,那么根据 f[i][j]=max(f[i1][jpw[i]]+v[i]p) ,我们可以得到式子

f[i]][j]=max(f[i1][w[i]t+b]v[i]t)+v[i]k
(j%w[i]=b)

具体实现就是第一层枚举 b ,第二层枚举 k ,通过队列 O(1) 得到 f[i1][w[i]t+b]v[i]t 的最优值。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#define M 105
using namespace std;
int n,m,a[M],c[M],f[100005];
int main()
{
    while (scanf("%d%d",&n,&m))
    {
        if (!n&&!m) break;
        for (int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        for (int i=1;i<=n;i++)
            scanf("%d",&c[i]);
        for (int i=1;i<=m;i++)
            f[i]=0;
        f[0]=1;
        for (int i=1;i<=n;i++)
        {
            if (c[i]==1)
            {
                for (int j=m;j>=a[i];j--)
                    f[j]|=f[j-a[i]];
                continue;
            }
            if (c[i]*a[i]>=m)
            {
                for (int j=a[i];j<=m;j++)
                    f[j]|=f[j-a[i]];
                continue;
            }
            for (int j=0;j<a[i];j++)
            {
                int la=-100000000;
                for (int k=0;k<=(m-j)/a[i];k++)
                {
                    int t=k*a[i]+j;
                    if (f[t])
                    {
                        la=k;
                        continue;
                    }
                    else
                    {
                        if (k-la<=c[i])
                            f[t]=1;
                    }
                }
            }
        }
        int ans=0;
        for (int i=1;i<=m;i++)
            ans+=f[i];
        printf("%d\n",ans);
    }
    return 0;
}

这里写图片描述

你可能感兴趣的:(poj,OI,队列优化多重背包)