AYITACM2016省赛第三周 J - Longest Run on a Snowboard(dp记忆化搜索)


Michael likes snowboarding. That’s not very surprising, since snowboarding is really great. The bad
thing is that in order to gain speed, the area must slide downwards. Another disadvantage is that when
you’ve reached the bottom of the hill you have to walk up again or wait for the ski-lift.
Michael would like to know how long the longest run in an area is. That area is given by a grid of
numbers, defining the heights at those points. Look at this example:
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
One can slide down from one point to a connected other one if and only if the height decreases. One
point is connected to another if it’s at left, at right, above or below it. In the sample map, a possible
slide would be 24-17-16-1 (start at 24, end at 1). Of course if you would go 25-24-23-. . . -3-2-1, it would
be a much longer run. In fact, it’s the longest possible.
Input
The first line contains the number of test cases N. Each test case starts with a line containing the
name (it’s a single string), the number of rows R and the number of columns C. After that follow R
lines with C numbers each, defining the heights. R and C won’t be bigger than 100, N not bigger than
15 and the heights are always in the range from 0 to 100.
Output
For each test case, print a line containing the name of the area, a colon, a space and the length of the
longest run one can slide down in that area.
Sample Input
2
Feldberg 10 5
56 14 51 58 88
26 94 24 39 41
24 16 8 51 51
76 72 77 43 10
38 50 59 84 81
5 23 37 71 77
96 10 93 53 82
94 15 96 69 9
74 0 62 38 96
37 54 55 82 38
Spiral 5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
Sample Output
Feldberg: 7
Spiral: 25

分析:

dp记忆化搜索,前面搜索过的后面就可以跳过,直接向后走,优化程序,缩短时间,增加效率;

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,m,a[120][120],x,y,dp[120][120];
int v[4][2]= {1,0,-1,0,0,-1,0,1};
int dfs(int x1,int y1)
{
    if(dp[x1][y1]) //如果这个在前边路径中已经走过,就不用再搜索
        return dp[x1][y1];
    int ans=0;
    for(int i=0; i<4; i++)
    {
        int nx=x1+v[i][0];
        int ny=y1+v[i][1];
        if(nx>=0&&nx<x&&ny>=0&&ny<y&&a[x1][y1]>a[nx][ny])
            ans=max(ans,1+dfs(nx,ny)); //找到最优解
    }
    if(ans==0)//如果当前值为最小值,步数为1;
        return dp[x1][y1]=1;
    return dp[x1][y1]=ans; //返回最优解
}
int main()
{
    int i,j,k,t;
    char s[30];
    scanf("%d",&n);
    while(n--)
    {
        memset(dp,0,sizeof(dp));
        scanf("%s %d%d",s,&x,&y);
        for(i=0; i<x; i++)
            for(j=0; j<y; j++)
                scanf("%d",&a[i][j]);
        m=0;
        for(i=0; i<x; i++)
            for(j=0; j<y; j++)
                m=max(m,dfs(i,j));//搜索路径,顺便找到最大值
        printf("%s: %d\n",s,m);
    }
    return 0;
}



你可能感兴趣的:(AYITACM2016省赛第三周 J - Longest Run on a Snowboard(dp记忆化搜索))