HDOJ 1007-Quoit Design【模板:多点求最短距离(非整数点)】

Quoit Design

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 44862    Accepted Submission(s): 11638


Problem Description
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.
 

Input
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.
 

Output
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places. 
 

Sample Input
   
   
   
   
2 0 0 1 1 2 1 1 1 1 3 -1.5 0 0 0 0 1.5 0
 

Sample Output
   
   
   
   
0.71 0.00 0.75
 

Author
CHEN, Yue
 

Source
ZJCPC2004
 
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
const double eps=1e-8;
const int maxn=1e6;
const double inf=1e20;
struct point
{
	double x,y;
}p[maxn],tp[maxn];
double dist(point a,point b)
{
	return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
bool cmpxy(point a,point b)
{
	if(a.x==b.x)
	{
		return a.y<b.y;
	}
	return a.x<b.x;
}
bool cmpy(point a,point b)
{
	return a.y<b.y;
}
double cl(int left,int right)
{
	double d=inf;
	if(left==right)
	{
		return d;
	}
	if(left+1==right)
	{
		return dist(p[left],p[right]); 
	}
	int mid=(left+right)>>1;
	double d1=cl(left,mid);
	double d2=cl(mid+1,right);
	d=min(d1,d2);
	int k=0;
	for(int i=left;i<=right;i++)
	{
		if(fabs(p[mid].x-p[i].x)<=d)
		{
			tp[k++]=p[i];
		}
	}
		sort(tp,tp+k,cmpy);
		for(int i=0;i<k;i++)
		{
			for(int j=i+1;j<k&&tp[j].y-tp[i].y<d;j++)
			{
				d=min(d,dist(tp[i],tp[j]));
			}
		}
	return d;
}
int main()
{
	int n;
	while(scanf("%d",&n),n)
	{
		for(int i=0;i<n;i++)
		{
			scanf("%lf%lf",&p[i].x,&p[i].y);
		}
		sort(p,p+n,cmpxy);
		double ans=cl(0,n-1)/2.0;
		printf("%.2lf\n",ans);
	}
	return 0;
 }  


你可能感兴趣的:(模板,多点求最短距离)