数据结构实验之链表四:有序链表的归并

数据结构实验之链表四:有序链表的归并

Time Limit: 1000MS Memory limit: 65536K

题目描述

分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。

输入

第一行输入M与N的值; 
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。

输出

输出合并后的单链表所包含的M+N个有序的整数。

示例输入

6 5
1 23 26 45 66 99
14 21 28 50 100

示例输出

1 14 21 23 26 28 45 50 66 99 100

提示

不得使用数组!

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct node
{
    int data;
    struct node *next;
};
struct node *creat(int n)
{
    struct node *head, *tail, *q;
    head = (struct node *)malloc(sizeof(struct node));
    head->next =NULL;
    tail = head;
    int i;
    for(i = 0;i <n;i++){
        q = (struct node *)malloc(sizeof(struct node));
        q->next = NULL;
        scanf("%d", &q->data);
        tail->next = q;
        tail = q;
    }
    return head;
}
struct node *merge(struct node *head1, struct node *head2)
{
    struct node *p1, *p2, *tail;
    tail = head1;
    p1 = head1->next;
    p2 = head2->next;
    while(p1 && p2){
        if(p1->data > p2->data){
            tail->next = p2;
            tail = p2;
            p2 = p2->next;
        }else {
            tail->next = p1;
            tail = p1;
            p1 = p1->next;
        }
    }
    if(p1 == NULL){
        tail->next= p2;
    }else {
        tail->next= p1;
    }
    return head1;
}
int main()
{
    int n, m;
    scanf("%d %d", &n, &m);
    struct node *head1, *head2, *head, *p;
    head1 = creat(n);
    head2 = creat(m);
    head = merge(head1, head2);
    p = head->next;
    while(p != NULL){
        if(p->next != NULL){
            printf("%d ", p->data);
        }else {
            printf("%d", p->data);
        }
        p = p->next;
    }

    return 0;
}


你可能感兴趣的:(数据结构实验之链表四:有序链表的归并)