hdu2028!【水题】

Lowest Common Multiple Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33156    Accepted Submission(s): 13536


Problem Description
求n个数的最小公倍数。
 

Input
输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数。
 

Output
为每组测试数据输出它们的最小公倍数,每个测试实例的输出占一行。你可以假设最后的输出是一个32位的整数。
 

Sample Input
   
   
   
   
2 4 6 3 2 5 7
 

Sample Output
   
   
   
   
12 70
 

Author
lcy
 

Source
C语言程序设计练习(五)
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2031  2029  2030  2035  2034 
#include<stdio.h>
#include<stdlib.h>
int gcd(int x, int y)
{
	if(y == 0)
	return x;
	return gcd(y, x%y);
}
int cmp(const void *a, const void *b)
{
	return *(int *)a - *(int *)b;
}
int main()
{
	int i, a[1000], n;
	__int64 k;
	while(scanf("%d", &n) != EOF)
	{
		for(i = 0 ; i <  n; i++)
		scanf("%d", &a[i]);
		qsort( a , n, sizeof(a[0]), cmp);
		k = ( __int64 ) a[0] * ( __int64 )a[1] 	/ ( __int64 )gcd(a[0], a[1]);//  note
		for(i = 2; i < n; i++) 
		k = k * ( __int64 )a[i] / ( __int64 )gcd((int)k, a[i]);//note  
		printf("%I64d\n", k);
	}
	return 0;
} 
唯一要注意的是两个32位的数相乘,有可能会大于32位, 所以数据保存的时候要稍作处理

你可能感兴趣的:(c)