The Dole Queue(UVA 133)

The Dole Queue
Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

Submit Status

Description

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0

Sample output

 4  8,  9  5,  3  1,  2  6,  10,  7

where  represents a space.

#include<iostream>
#include<stdlib.h>
#include<cstdio>
#include<algorithm>
#include<map>
#include<string.h>
#define maxn 35
using namespace std;
bool a[maxn];
int main(){
//freopen("in.txt","r",stdin);
int n,k,m;
while(scanf("%d%d%d",&n,&k,&m)==3&&n!=0){
for(int i=0;i<maxn;i++){
a[i]=1;//初始化每个人都在队列中 
}
int A=0,B=n-1,t=n;
int i=A,j=B;
while(t>0){
int s1=k,s2=m;
while(t>0){
if(a[i]==0) i++;
else if(a[i]==1&&s1!=1){
s1--;
i++;
}
else if(a[i]==1&&s1==1){
t--;
A=i;
if(A+1<10) printf("  ");
else printf(" "); //格式控制
printf("%d",A+1);
break;

if(i>=n) i=i%n;

}//模拟A的走法 
while(t>0){
if(j<0) j+=n;
if(a[j]==1&&s2!=1){
s2--;
j--;
}
else if(a[j]==0) j--;
else if(a[j]==1&&s2==1){
B=j;
if(A!=B){
if(B+1<10) printf("  ");
else printf(" ");//格式控制 
printf("%d",B+1);
t--;

break;
}
}//模拟B的走法 
if(t!=0) printf(",");
a[i]=a[j]=0;//人离开队列 
}
printf("\n");
}

}

你可能感兴趣的:(The Dole Queue(UVA 133))