hdu 1102 Constructing Roads

http://acm.hdu.edu.cn/showproblem.php?pid=1102

Problem Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

还是最小生成树问题

连通村庄

注意几个点
1.村庄的编号是从1开始不是0
2.已经连通的村庄就把他们的距离变成0

#include<iostream>
#include <cstdio>
#include <string.h>
#include <algorithm>
#include <math.h>
#define N 102 
#define MAX 1009
using namespace std;
int father[N], len[N][N], n, q, vis[N], d[N];

void prim()
{
    int i, j, min, ans = 0, v;
    for (i = 1; i <= n; i++)
    {
        d[i] = len[1][i];
    }

    vis[1] = 1;
    for(i = 2; i <= n; i++)
    {
        min = MAX;
        v = -1;
        for (j = 1; j <= n; j++)
        {
            if (!vis[j] && d[j] < min)
            {
                min = d[j];
                v = j;
            }
        }
        if (v != -1)
        {
            ans += d[v];
            vis[v] = 1;
            for (j = 1; j <= n; j++)
            {
                if (!vis[j] && d[j] > len[v][j])
                {
                    d[j] = len[v][j];
                }
            } 
        } 
    }
    cout << ans << endl; 
}

int main()
{
#ifndef ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
#endif
    int i, j, a, b;
    while(~scanf("%d", &n))
    {
        for (i = 1; i <= n; i++)
        {
            father[i] = i;
            vis[i] = 0;
        }
        for (i = 1; i <= n; i++)
        {
            for (j = 1; j <= n; j++)
            {
                scanf("%d", &len[i][j]);
            }
        }
        scanf("%d", &q);
        for (i = 0; i < q; i++)
        {
            scanf("%d%d", &a, &b);
            len[a][b] = len[b][a] = 0;
        }
        prim();
    }

    return 0;
}

你可能感兴趣的:(最小生成树,HDU,Prim)