zzuli蓝桥 text1 D find sum

爆搜题;

因为只有两个数想加

不需要用线段树区间求和;

Description

This problem is really boring.

You are given a number sequence S which contain n integers and m queries, each time i will give your two integers id1 and id2, you need to tell me whether i can get S[id1] + S[id2] from the n integers.

Input

Input starts with an integer T(T <= 5) denoting the number of test cases.
For each test case, n(1 <= n <= 100000, 1 <= m <= 10000) are given, and the second line contains n integers, each of them is larger then 0 and no larger than 10^11.
Next m lines, each line contains two integers id1 and id2(1 <= id1, id2 <= n).

Output

For each case, first print the case number.
For each query, print “Yes” if i can get S[id1] + S[id2] from S, otherwise print “No”(without the quote).

Sample Input

1
5 3
3 4 2 1 3
1 2
3 4
4 5

Sample Output

Case 1:
No
Yes
Yes


#include <iostream>
#include <cmath>
#include <algorithm>
#include <cstdio>
#include <cstring>
#define N 100000+100
int sum[N];
using namespace std ;
int main()
{
	int t ;
	scanf("%d",&t);
	for(int i = 1 ; i<=t;i++)
	{
		int n , m ;
		cin>>n>>m;
		int p , q ;
		for(int i = 1 ; i<=n;i++)
		{
			scanf("%d",&sum[i]);
		}
		printf("Case %d:\n",i);
		while(m--)
		{
			int flag = 0 ;
			cin>>p>>q;
			for(int i = 1 ; i <=n;i++)
			{
				if(sum[p]+sum[q]==sum[i])
				{
					printf("Yes\n");
					flag=1;
					break;
				}
			}
			if(!flag)
			printf("No\n");
		}
	}
	return 0 ;
}




你可能感兴趣的:(zzuli蓝桥 text1 D find sum)