【BZOJ 2060】 [Usaco2010 Nov]Visiting Cows 拜访奶牛

2060: [Usaco2010 Nov]Visiting Cows 拜访奶牛

Time Limit: 3 Sec Memory Limit: 64 MB
Submit: 257 Solved: 190
[Submit][Status][Discuss]
Description

经过了几周的辛苦工作,贝茜终于迎来了一个假期.作为奶牛群中最会社交的牛,她希望去拜访N(1<=N<=50000)个朋友.这些朋友被标号为1..N.这些奶牛有一个不同寻常的交通系统,里面有N-1条路,每条路连接了一对编号为C1和C2的奶牛(1 <= C1 <= N; 1 <= C2 <= N; C1<>C2).这样,在每一对奶牛之间都有一条唯一的通路. FJ希望贝茜尽快的回到农场.于是,他就指示贝茜,如果对于一条路直接相连的两个奶牛,贝茜只能拜访其中的一个.当然,贝茜希望她的假期越长越好,所以她想知道她可以拜访的奶牛的最大数目.
Input

第1行:单独的一个整数N 第2..N行:每一行两个整数,代表了一条路的C1和C2.
Output

单独的一个整数,代表了贝茜可以拜访的奶牛的最大数目.
Sample Input

7

6 2

3 4

2 3

1 2

7 6

5 6

INPUT DETAILS:

Bessie knows 7 cows. Cows 6 and 2 are directly connected by a road,

as are cows 3 and 4, cows 2 and 3, etc. The illustration below depicts the

roads that connect the cows:

                   1--2--3--4

                      |

                   5--6--7

Sample Output

4

OUTPUT DETAILS:

Bessie can visit four cows. The best combinations include two cows

on the top row and two on the bottom. She can’t visit cow 6 since

that would preclude visiting cows 5 and 7; thus she visits 5 and

  1. She can also visit two cows on the top row: {1,3}, {1,4}, or

{2,4}.

HINT

Source

Gold

树形dp水题。

f[i][0] 表示 i 不选,以 i 为根的子树的最大答案;
f[i][1] 表示 i 不选,以 i 为根的子树的最大答案。

f[i][0]=max(f[j][0],f[j][1])
f[i][1]=1+f[j][0]

#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <cstdio>
#define M 50005
using namespace std;
struct edge
{
    int y,ne;
}e[M*3];
int tot,h[M],f[M][2],n;
void Addedge(int x,int y)
{
    e[++tot].y=y;
    e[tot].ne=h[x];
    h[x]=tot;
}
void dfs(int x,int fa)
{
    f[x][1]=1,f[x][0]=0;
    for (int i=h[x];i;i=e[i].ne)
    {
        int y=e[i].y;
        if (y==fa) continue;
        dfs(y,x);
        f[x][1]+=f[y][0],f[x][0]+=max(f[y][1],f[y][0]);
    }
}
int main()
{
    scanf("%d",&n);
    for (int i=1;i<n;i++)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        Addedge(x,y);
        Addedge(y,x);
    }
    dfs(1,0);
    printf("%d\n",max(f[1][0],f[1][1]));
    return 0;
}

这里写图片描述

你可能感兴趣的:(OI,bzoj,树形DP)