Wooden Sticks
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17181 Accepted Submission(s): 7010
Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
Sample Output
一道不错的贪心题目
下面是ac代码(注意不要弄反 l 和 l' w 和 w' 的关系)
#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
#define maxn 10000
int a[maxn][5];
int main()
{
int zu,gen,n,i,j,x,temp,s,t,flags,ma;
while(scanf("%d",&zu)!=EOF)
{
while(zu--)
{ x=0;
flags=0;
memset(a,0,sizeof(a));
scanf("%d",&gen);
n=gen;
for(int x=0;x<gen;x++)
{
scanf("%d%d",&a[x][0],&a[x][1]);
}
gen=n;
//冒泡排序
for(i = 0; i < n; i++)
{
for(j = 0; j < n-i-1; j++)
{
if(a[j][0] > a[j + 1][0])
{
temp = a[j][0];
a[j][0] = a[j + 1][0];
a[j + 1][0] = temp;
//////
temp = a[j][1];
a[j][1] = a[j + 1][1];
a[j + 1][1] = temp;
}
}
}
//////////// 排序完成 ////////////
for(int i=0;i<n;i++)
{
if(a[i][2]==1)
continue;
else
x++;
ma=a[i][1];
for(int j=1;j<n;j++)
if(a[j][1]>=ma&&a[j][2]==0)
{
a[j][2]=1;
ma=a[j][1];
}
for(int e=1;e<n;e++)
{
if(a[e][2]==0)
{
flags=1;
break;
}
}
if(flags==1)
{
flags=0;
continue;
}
else
break;
}
printf("%d\n",x);
}
}
}
不会结构体的我只能用多维数组来代替了,排序的时候要手动冒泡排序才行,其中a[i][0]代表长度,a[i][1]代表重量,a[i][2] 来判断是否被锯过。