POJ 2001 Shortest Prefixes (字典树)

Shortest Prefixes
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 16531   Accepted: 7180

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents. 

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo". 

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car". 

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

Source

字典树典型的题目:

卡了一会,怎么也查不到,原来忘了建树了。- -!

题目大意:

给你一些单词,找出能代表这个单词的最短前缀,找不到就输出整个单词!

思路很明显:

先输入,把单词记录下来,可以开二维数组,也可以放进vector里面,边存边建树,然后就是查找,扫描每个单词,把每个单词拆开,遍历一个单词的每一个前缀,建树里面的v在这里就代表前缀出现的次数,只有v == 1 的时候才符合!


代码如下:


#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<vector>
using namespace std;
const int maxn = 26;

struct Trie{
    int id,v;
    Trie *next[maxn];
};
Trie *root;
void createTrie(const char *str){
    Trie *p = root, *q;
    int len = strlen(str);
    for (int i = 0; i < len; ++i){
        int id = str[i] - 'a';
        if (p->next[id] == NULL){
            q = new Trie;
            for (int j = 0; j < maxn; ++j)q->next[j] = NULL;
            q->v = 1;
            p->next[id]= q;
            p=q;
        }else {
            p->next[id]->v++;
            p=p->next[id];
        }
    }
}
int findTrie(const char *str){
    Trie *p = root;
    int len = strlen(str);
    for (int i = 0; i < len; ++i){
        int id = str[i] - 'a';
        p=p->next[id];
        if (p == NULL)return 0;
    }
    return p->v;
}
int main()
{
    root = new Trie;
    for (int i = 0; i < maxn; ++i)root->next[i] = NULL;
    vector<string>v;
    string s,a,b;
    while(cin >> s){
        v.push_back(s);
        const char *pp = s.data();
        createTrie(pp);
    }
    for(int i = 0; i < (int)v.size(); ++i){
        s = v[i];
        int len = (int)s.length();
        bool ok = false;
        cout << s << " ";
        for (int k = 1; k < len; ++k){
            a = s.substr(0,k);
            const char *pp1 = a.data();
            if (findTrie(pp1) == 1){ok=true;printf("%s\n",pp1);break;}
        }
        if (!ok)cout << s << endl;
    }
    return 0;
}


你可能感兴趣的:(C语言,poj)