HDU 1025 Constructing Roads In JGShining's Kingdom

HDU 1025 Constructing Roads In JGShining’s Kingdom

Problem Description
JGShining’s kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they’re unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don’t wanna build a road with other poor ones, and rich ones also can’t abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities … And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.
HDU 1025 Constructing Roads In JGShining's Kingdom_第1张图片
In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^

Input
Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.

Output
For each test case, output the result in the form of sample.
You should tell JGShining what’s the maximal number of road(s) can be built.

Sample Input
2
1 2
2 1
3
1 2
2 3
3 1

Sample Output
Case 1:
My king, at most 1 road can be built.

Case 2:
My king, at most 2 roads can be built.

Hint
Huge input, scanf is recommended.

题目好长啊!!!
讨厌英文题╥﹏╥…

总之,题目的大致意思就是说,富裕的城市在一边,贫穷的城市在一边,现在在富裕的城市和贫穷的城市之间修路,一个城市只和另一个城市修一条路,而且道路不能相交,相交了容易出事故。问最多能够修都少条路

首先,我们先按贫穷的城市排序,然后就是求富裕的城市中最长上升子序列,下面使用 的方法是动态规划+二分搜素,复杂度为o(nlogn)(详情见http://blog.csdn.net/qq_21120027/article/details/47756377)

还有一点,当只能修一条路是,road没有s /(ㄒoㄒ)/~~

#include<iostream>
#include <cstdio>
#include <algorithm>
#include <string.h>
#define N 2010
using namespace std;
struct link
{
    int poor;
    int rich;
    friend bool operator < (const link &a, const link &b) 
    {
        return a.poor < b.poor;
    }
}node[50005];
int MaxV[50005], len, n;

int search(int size, int x)
{
    int left = 0, right = size - 1, mid;
    while(left <= right)
    {
        mid = (left + right)/2;
        if (MaxV[mid] <= x)
        {
            left = mid + 1;
        }
        else
        {
            right = mid - 1;
        }
    }
    return left;
}

void LIS()
{
    MaxV[0] = node[0].rich;
    len = 1;
    for (int i = 1; i < n; i++)
    {
        if (node[i].rich >= MaxV[len - 1])
        {
            MaxV[len++] = node[i].rich;
        }
        else
        {
            int pos = search(len, node[i].rich);
            MaxV[pos] = node[i].rich;
        }
    }
}

int main()
{
#ifndef ONLINE_JUDGE 
    freopen("1.txt", "r", stdin);
#endif
    int i, cases = 0;
    while(~scanf("%d", &n))
    {
        for (i = 0; i < n; i++)
        {
            scanf("%d%d", &node[i].poor, &node[i].rich);
        }
        sort(node, node+n);
        LIS();
        printf("Case %d:\nMy king, at most %d road", ++cases, len);
        if (len == 1)
        {
            printf(" can be built.\n\n");
        }
        else
        {
            printf("s can be built.\n\n");
        }
    }
    return 0;
}

你可能感兴趣的:(HDU)