Let the Balloon Rise

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 85959 Accepted Submission(s): 32465

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

代码:

#include<iostream>
using namespace std;

#define MAXSIZE 1000
#define COLOR_LEN 16

int main(void)
{
    int N;
    char arr[MAXSIZE][COLOR_LEN];
    int num[MAXSIZE] = {};
    while (cin >> N && N > 0)
    {
        memset(arr, '0', sizeof(arr));
        for (int i = 0; i < N; ++i)
        {
            num[i] = 1;
            cin >> arr[i];
            for (int j = 0; j < i; ++j)
            {
                if (strcmp(arr[i], arr[j]) == 0)
                {
                    ++num[i];
                }
            }
        }

        int maxIndex = 0;
        for (int i = 1; i < N; i++)
        {
            if (num[i]> num[maxIndex])
            {
                maxIndex = i;
            }
        }
        cout << arr[maxIndex] << endl;
    }
    return 0;
}

PS: 在HDOJ中提交代码的时候注意不要使用 fflush(stdin); (清除输入缓冲区),我也是醉了,提交了那么久,就是因为这句话导致 wrong answer,删掉就好了。

你可能感兴趣的:(Let-the-Ba,杭电1004题)