POJ 1979 && HDU 1312 Red and Black(DFS)

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
#include <iostream>
#include <cstdio>
using namespace std;
char map[25][25];
int num;
int w,l;//w->width l->lenth
int dx[4] ={0,0,1,-1};
int dy[4] ={1,-1,0,0};
void dfs(int x,int y)
{
    int i,xx,yy;
    for(i=0;i<4;i++)
    {
        xx = x+dx[i];
        yy = y+dy[i];
        if(xx>=0 && xx<w && yy>=0 && yy<l && map[xx][yy]=='.')
        {
            num++;
            map[xx][yy] = '@';
            dfs(xx,yy);
        }
    }
}
int main()
{
    //freopen("test.txt","r",stdin);
    int i,j;
    int sx,sy;
    while(cin>>l>>w && l)
    {
        for(i=0;i<w;i++)
        {
            for(j=0;j<l;j++)
            {
                cin>>map[i][j];
                if(map[i][j]=='@')
                {
                    sx = i;
                    sy = j;
                }//
            }
        }
        map[sx][sy] = '#';
        num = 1;
        dfs(sx,sy);
        cout << num << endl;
    }
    //cout << "Hello world!" << endl;
    return 0;
}

你可能感兴趣的:(ACM,poj,HDU,DFS)