Key Set
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1384 Accepted Submission(s): 761
Problem Description
soda has a set
S with
n integers
{1,2,…,n} . A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of
S are key set.
Input
There are multiple test cases. The first line of input contains an integer
T
(1≤T≤105) , indicating the number of test cases. For each test case:
The first line contains an integer
n
(1≤n≤109) , the number of integers in the set.
Output
For each test case, output the number of key sets modulo 1000000007.
Sample Input
Sample Output
Author
zimpha@zju
Source
2015 Multi-University Training Contest 6
题意:给你一个具有n个元素的集合S{1,2,…,n},问集合S的非空子集中元素和为偶数的非空子集有多少个。
解:答案是2^n-1,用快速幂,不然要超时
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define LL __int64
const LL mod=1e9+7;
LL quick_mod(LL x,LL n)//快速幂
{
LL ans=1;
x=x%mod;
while(n)
{
if(n&1)
ans=(ans*x)%mod;
n>>=1;
x=(x*x)%mod;
}
return ans;
}
int main()
{
LL t;
scanf("%I64d",&t);
while(t--)
{
LL n;
scanf("%I64d",&n);
printf("%I64d\n",quick_mod(2,n-1)-1);
}
return 0;
}