1009. Product of Polynomials (25)

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output

3 3 3.6 2 6.0 1 1.6


IDEA

将指数作为数组索,存储其系数

CODE

#include<iostream>
#include<iomanip>
using namespace std;
int main(){
	double a[1002]={0},b[1002]={0};
	double result[2002]={0};
	int k1,k2;
	int exp;
	double coe;
//	a[1]=2.4;a[0]=3.2;
//	b[2]=1.5;b[1]=0.5;
	cin>>k1;
	for(int i=0;i<k1;i++){
		cin>>exp>>coe;
		a[exp]=coe;		
	}
	cin>>k2;
	for(int i=0;i<k2;i++){
		cin>>exp>>coe;
		b[exp]=coe;
	}
	for(int i=0;i<1001;i++){
		if(a[i]){
			for(int j=0;j<1001;j++){
				if(b[j]){
					result[i+j]+=(a[i]*b[j]);
					//cout<<result[i+j]<<endl;
				}
				
			}
		}
	
	}
	int count=0;
	for(int i=0;i<2001;i++){
		if(result[i]){
			count++;
		}
	}
	cout<<count;
	for(int i=2000;i>=0;i--){
		if(result[i]){
			cout<<fixed<<setprecision(1)<<" "<<i<<" "<<result[i];
		}
	}
	return 0;
}

1009. Product of Polynomials (25)_第1张图片

你可能感兴趣的:(pat,多项式相乘)