Anniversary party
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8044 Accepted Submission(s): 3507
Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
Output
Output should contain the maximal sum of guests' ratings.
Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
Sample Output
Source
Ural State University Internal Contest October'2000 Students Session
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
const int maxn = 6050;
int fa[maxn],dp[maxn][2],vis[maxn]; //dp[i][0]表示第i个人参加了聚会,dp[i][1]表示第i个人没有参加聚会
vector <int> vec[maxn]; //利用vector数组来存父节点的所有子节点
int n;
void Find(int root)
{
vis[root] = 1;
for(int i = 0; i < vec[root].size(); i++)
{
int temp = vec[root][i];
if(!vis[temp])
{
Find(temp);
dp[root][0] += max(dp[temp][0],dp[temp][1]); //如果这个人没有参加,那么就可以从下属参加或者不参加中2个情况中选较大值
dp[root][1] += dp[temp][0]; //这个人你参加了聚会,所以下属一定不能参加聚会了。
}
}
}
int main()
{
while(scanf("%d", &n) != EOF)
{
memset(dp,0,sizeof(dp));
memset(fa,0,sizeof(fa));
memset(vis,0,sizeof(vis));
for(int i = 1; i <= n; i++)
{
scanf("%d",&dp[i][1]);
vec[i].clear();
}
int x,y;
int root = 0;
while(scanf("%d%d",&x,&y) != EOF && (x||y))
{
vec[y].push_back(x);
fa[x] = y;
if(!root) root = y;
}
while(fa[root]) //这里需要注意利用fa[]数组来找到根节点。
root = fa[root];
Find(root);
printf("%d\n",max(dp[root][0],dp[root][1]));
}
return 0;
}