额,这题我刚开始看错题目了%>_<%,,后面每行的第一个数是指个数。。
Least Common Multiple
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28673 Accepted Submission(s): 10770
Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1
Sample Output
程序如下:
//先用碾转相除法求最小公约数,再求公倍数
#include<stdio.h>
int gcd(int a,int b) //碾转相除
{
if(b==0) return a;
return gcd(b,a%b);
}
int main()
{
int t,n,i,a,b;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
if(n==1) //只给出一个数的情况
{
scanf("%d",&a);
printf("%d\n",a);
continue;
}
scanf("%d%d",&a,&b);
a=a/gcd(a,b)*b; //这样做比较保险,如用a*b/gcd(a,b)可能会超出int范围
for(i=0; i<n-2; i++)
{
scanf("%d",&b);
a=a/gcd(a,b)*b;
}
printf("%d\n",a);
}
return 0;
}