hdu 4296 Buildings

Buildings

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3229    Accepted Submission(s): 1219


Problem Description
  Have you ever heard the story of Blue.Mary, the great civil engineer? Unlike Mr. Wolowitz, Dr. Blue.Mary has accomplished many great projects, one of which is the Guanghua Building.
  The public opinion is that Guanghua Building is nothing more than one of hundreds of modern skyscrapers recently built in Shanghai, and sadly, they are all wrong. Blue.Mary the great civil engineer had try a completely new evolutionary building method in project of Guanghua Building. That is, to build all the floors at first, then stack them up forming a complete building.
  Believe it or not, he did it (in secret manner). Now you are face the same problem Blue.Mary once stuck in: Place floors in a good way.
  Each floor has its own weight w i and strength s i. When floors are stacked up, each floor has PDV(Potential Damage Value) equal to (Σw j)-s i, where (Σw j) stands for sum of weight of all floors above.
  Blue.Mary, the great civil engineer, would like to minimize PDV of the whole building, denoted as the largest PDV of all floors.
  Now, it’s up to you to calculate this value.
 

Input
  There’re several test cases.
  In each test case, in the first line is a single integer N (1 <= N <= 10 5) denoting the number of building’s floors. The following N lines specify the floors. Each of them contains two integers w i and s i (0 <= w i, s i <= 100000) separated by single spaces.
  Please process until EOF (End Of File).
 

Output
  For each test case, your program should output a single integer in a single line - the minimal PDV of the whole building.
  If no floor would be damaged in a optimal configuration (that is, minimal PDV is non-positive) you should output 0.
 

Sample Input
   
   
   
   
3 10 6 2 3 5 4 2 2 2 2 2 3 10 3 2 5 3 3
 

Sample Output
   
   
   
   
1 0 2
 

Source
2012 ACM/ICPC Asia Regional Chengdu Online



贪心题,考虑相邻的两层,假设它们之上的重量和为sum,分别计算不同上下位置关系时,它们的PDV,比较后发现,决定它们上下关系的是它们w+s的大小,之后就贪心即可;


#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
struct Floor
{
    int w;
    int s;
}s[100005];
bool cmp(const Floor& a,const Floor& b)
{
    return a.w+a.s<b.w+b.s;
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<n;++i)
        {
            scanf("%d %d",&s[i].w,&s[i].s);
        }
        sort(s,s+n,cmp);
        long long int ans=0;
        long long int sum=0;
        for(int i=0;i<n;++i)
        {
            long long int temp=sum-s[i].s;
            if(temp>ans) ans=temp;
            sum+=s[i].w;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}


你可能感兴趣的:(HDU,贪心)