UVA 674 - Coin Change

UVA 674 - Coin Change


Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

Input
The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

Output
For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

Sample Input
11
26

Sample Output
4
13

多重背包问题。不过我是用深搜+记忆化写的,

#include<iostream>
#include <algorithm>
#include <cstdio>
#include <string.h>
#define N 8000
using namespace std;
const int coin[5]={1, 5, 10, 25, 50};
int dp[N][5], n;
int dfs(int remain, int i)
{
    if (dp[remain][i] != -1)
    {
        return dp[remain][i];
    }
    dp[remain][i] = 0;
    for (int j = i; j < 5 && coin[j] <= remain; j++)
    {
        dp[remain][i] += dfs( remain - coin[j], j);
    }
    return dp[remain][i];
}
int main()
{
#ifndef ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
#endif
    int i, j;
    memset(dp, -1, sizeof(dp));
    for(i = 0;  i < 5; i++)
    {
        dp[0][i] = 1;
    }
    dfs(7500, 0);
    while(~scanf("%d", &n))
    {
        cout << dp[n][0] << endl;
    }
    return 0;
} 

你可能感兴趣的:(uva)