HDU-2844-Coins

Problem Description

Whuacmers use coins.They have coins of value A1,A2,A3…An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input

The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

多重背包模板题

代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <cmath>
#include <algorithm>
#define N 110
#define INF 1000000001
#define ll long long
using namespace std;
int n, m;
int A[N], C[N], dp[100010];
int main()
{
#ifndef ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
#endif
    ios::sync_with_stdio(false);
    cin.tie(0);
    int i, j, k, ans;
    while(cin >> n >> m, n||m)
    {
        for (i = 0; i < n; i++)
            cin >> A[i];
        for (i = 0; i < n; i++)
            cin >> C[i];
        memset(dp, 0,sizeof(dp));
        for (i = 0; i < n; i++)
        {
            if (A[i]*C[i] >= m)
            {
                for (j = A[i]; j <= m; j++)
                    dp[j] = max(dp[j], dp[j-A[i]] + A[i]);
            }
            else
            {
                k = 1;
                while(k < C[i])
                {
                    for (j = m; j >= k*A[i]; j--)
                        dp[j] = max(dp[j], dp[j-k*A[i]]+k*A[i]);
                    C[i] -= k;
                    k <<= 1;
                }
                for (j = m; j >= C[i]*A[i]; j--)
                    dp[j] = max(dp[j], dp[j-C[i]*A[i]]+C[i]*A[i]);
            }
        }
        for (i = 1, ans = 0; i <= m; i++)
            if (dp[i] == i) ans++;
        cout << ans << endl;
    }
    return 0;
} 

你可能感兴趣的:(HDU-2844-Coins)