Problem Description
Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute difference between the two scores.
Given the winning numbers for each type of bet, can you deduce the final scores?
Input
The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.
Output
For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing "impossible". Recall that football scores are always non-negative integers.
Sample Input
Sample Output
题目大意:粗心了,给定两个数字的和, 差, 要求出这两个数字是多少;
题解:唯一考虑的点是,只有偶+偶 , 奇+奇 ,才能得到偶; 额外判断; 而且和不可能比差小; 如果得到答案后应该调换 ;
AC代码:
#include <bits/stdc++.h>
using namespace std ;
int main()
{
int a , b , t ;
cin>>t;
while(t--)
{
cin>>a>>b;
if(a<b) printf("impossible\n");
else if((a+b)%2!=0) printf("impossible\n");
else
{
int m , n ;
m = (a+b)/2 ;
n = (a-b)/2 ;
if(n>m) swap(m,n);
printf("%d %d\n",m,n);
}
}
return 0 ;
}