Description
给出一个数num的质因数分解形式,输出num-1的质因数分解形式
Input
多组输入,每组用例占一行,输入形式为p1 k1 p2 k2……pn kn(num=p1^k1*p2^k2*……*pn^kn),以0结束输入
Output
对于每组用例,输出num-1的素因数分解形式(同输入形式)
Sample Input
17 1
5 1 2 1
509 1 59 1
0
Sample Output
2 4
3 2
13 1 11 1 7 1 5 1 3 1 2 1
Solution
简单素因数分解,注意用字符串读入
Code
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<string>
using namespace std;
#define maxn 33333
#define INF 0x3f3f3f3f
typedef long long ll;
int prime[maxn],cnt;
bool is_prime[maxn];
ll mod_pow(int a,int b)
{
ll ans=1;
while(b)
{
if(b&1)
ans=ans*a;
a=a*a;
b>>=1;
}
return ans;
}
void get_prime()
{
cnt=1;
memset(is_prime,true,sizeof(is_prime));
for(int i=2;i<maxn;i++)
if(is_prime[i])
{
prime[cnt++]=i;
for(int j=2*i;j<maxn;j+=i)
is_prime[j]=false;
}
}
int main()
{
get_prime();//预处理出素数表
char s[maxn];
while(gets(s)&&s[0]!='0')
{
int i=0;
int a=0,b=0;
ll ans=1;
while(i<strlen(s))
{
while(s[i]==' ')//可能有多个空格
i++;
while(s[i]!=' ')//读取素因数
a=a*10+s[i++]-'0';
while(s[i]==' ')//可能有多个空格
i++;
while(s[i]!=' '&&i<strlen(s))//读取素因数的幂级数
b=b*10+s[i++]-'0';
ans*=mod_pow(a,b);//累乘ans
a=0;//注意初始化a,b的值
b=0;
}
ans--;
int res=1;
int ans1[maxn],ans2[maxn],k=0;//ans1存储素因数,ans2存储素因数对应的幂级数
if(ans==1)//特判ans=1的情况
{
ans1[k]=1;
ans2[k++]=1;
}
while(ans>1&&res<cnt)//素因数分解
{
int num=0;
while(ans%prime[res]==0)
{
ans/=prime[res];
num++;
}
if(num)
{
ans1[k]=prime[res];
ans2[k++]=num;
}
res++;
}
if(ans>1)//ans仍然大于1说明此时ans是一个大素数
{
ans1[k]=ans;
ans2[k++]=1;
}
for(int i=k-1;i>=0;i--)
printf("%d %d%c",ans1[i],ans2[i],i==0?'\n':' ');
}
return 0;
}