【PAT乙级真题及训练集】【1002】写出这个数 (20)

1002. 写出这个数 (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

读入一个自然数n,计算其各位数字之和,用汉语拼音写出和的每一位数字。

输入格式:每个测试输入包含1个测试用例,即给出自然数n的值。这里保证n小于10100

输出格式:在一行内输出n的各位数字之和的每一位,拼音数字间有1 空格,但一行中最后一个拼音数字后没有空格。

输入样例:
1234567890987654321123456789
输出样例:
yi san wu
没什么好说的,以前都是用数组,这次用stack容器试试,果然a了。 一开始WA两次,后来发现错误的原因是因为ling写成lin了。。。sad
#include "stdio.h"
#include "string.h"
#include "algorithm"
#include "stack"
#include "iostream"
using namespace std;
char ans[11][11]={"ling","yi","er","san","si","wu","liu","qi","ba","jiu","wa"};
int main(int argc, char const *argv[])
{
	char str[1000];
	while(gets(str)!=NULL)
	{
		int sum;
		stack<int> a;
		for (int i = 0; i < strlen(str); ++i)
		{
			sum+=str[i]-'0';
		}
		if(sum==0)
		{
			printf("ling");
		}
		while(sum!=0)
		{
			int temp=sum%10;
			a.push(temp);
			sum/=10;
		}
		while(!a.empty())
		{
			int temp=a.top();
			a.pop();
			printf("%s",ans[temp]);
			if(!a.empty())
				printf(" ");
		}
		printf("\n");
	}
	return 0;
}

你可能感兴趣的:(c,水题)