1011. World Cup Betting (20)

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

W T L
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1
To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

Input

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1
Sample Output
T T W 37.98

IDEA

被这道题给坑了,自己写出代码输入test case结果不对,手工算了一下,结果是37.975,它给的结果是37.98

想着估计是四舍五入了,就自己自己搞出来四舍五入的结果,提交PAT发现全错,我就凌乱了。。。。这道题有问题

系统认为直接保留两位就好!!!

CODE

#include<iostream>
#include<iomanip>
using namespace std;
int main(){
	double a[3];
	double product=1,result;
	for(int i=0;i<3;i++){
		double max=0;
		int flag=0;
		int j;
		for(int j=0;j<3;j++){		
			cin>>a[j];
			if(max<a[j]){
				max=a[j];
				flag=j;
			}
		}
		switch(flag){
			case 0:cout<<"W"<<" ";break;
			case 1:cout<<"T"<<" ";break;
			case 2:cout<<"L"<<" ";break;
		}
		product*=max;	
	}
	result=(product*0.65-1)*2;
	cout<<fixed<<setprecision(2)<<result;
	return 0;
}


你可能感兴趣的:(pat)