POJ 【3518】 Prime Gap

Prime Gap
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 9642   Accepted: 5546

Description

The sequence of n − 1 consecutive composite numbers (positive integers that are not prime and not equal to 1) lying between two successive prime numbers p and p + n is called a prime gap of length n. For example, ‹24, 25, 26, 27, 28› between 23 and 29 is a prime gap of length 6.

Your mission is to write a program to calculate, for a given positive integer k, the length of the prime gap that contains k. For convenience, the length is considered 0 in case no prime gap contains k.

Input

The input is a sequence of lines each of which contains a single positive integer. Each positive integer is greater than 1 and less than or equal to the 100000th prime number, which is 1299709. The end of the input is indicated by a line containing a single zero.

Output

The output should be composed of lines each of which contains a single non-negative integer. It is the length of the prime gap that contains the corresponding positive integer in the input if it is a composite number, or 0 otherwise. No other characters should occur in the output.

Sample Input

10
11
27
2
492170
0

Sample Output

4
0
6
0
114

Source

Japan 2007

#include <cstdio>
#include <iostream>
#include <cmath>
#include <cstring>
using namespace std;
const int maxn = 1300000;
int prime[maxn];
int vis[maxn];

void init()
{
    int m = sqrt(maxn);
    memset(vis,0,sizeof(vis));
    for(int i = 2; i < m; i++)if(!vis[i])
        for(int j = i*i; j < maxn; j += i)
            vis[j] = 1;
    int flag = 0;
    for(int i = 2; i < maxn; i++)
        if(!vis[i]) prime[flag++] = i;
}

int main()
{
    init();
    int n;
    while(scanf("%d", &n) != EOF && n)
    {
        int flag = 0;
        for(int i = 1; i < 100000; i++)
        {
            if(n > prime[i-1] && n < prime[i])
            {
                flag = prime[i] - prime[i-1];
                break;
            }
        }
        printf("%d\n", flag);
    }
    return 0;
}

你可能感兴趣的:(素数,数论)