HDOJ 2602 Bone Collector(01背包)

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 39999    Accepted Submission(s): 16595


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
HDOJ 2602 Bone Collector(01背包)_第1张图片
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
   
   
   
   
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
   
   
   
   
14 ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define MAXN 10010
#define INF 0xfffffff
#define max(a,b) a>b?a:b
#define min(a,b) a>b?b?a
using namespace std;
struct s
{
	int p;
	int v;
}a[MAXN];
bool cmp(s a,s b)
{
	if(a.v==b.v)
	return a.p<b.p;
	return a.v>b.v;
}
int dp[MAXN];
int main()
{
	int n,m;
	int i,j;
	int t;
	scanf("%d",&t);
	while(t--)
	{
	    scanf("%d%d",&n,&m);
		for(i=0;i<n;i++)
		scanf("%d",&a[i].v);
		for(i=0;i<n;i++)
		scanf("%d",&a[i].p);
		sort(a,a+n,cmp);
		memset(dp,0,sizeof(dp));
		for(i=0;i<n;i++)
		{
			for(j=m;j>=a[i].p;j--)
			{
				dp[j]=max(dp[j],dp[j-a[i].p]+a[i].v);
			}
		}
		printf("%d\n",dp[m]);
	}
	return 0;
}



你可能感兴趣的:(HDOJ 2602 Bone Collector(01背包))