POJ1664放苹果

Description
We are going to place M same apples into N same plates.
There could be some empty plates.
How many methods do we have?
When we have 7 applesand 3 plates, the methods, (1, 5, 1) and (5, 1, 1) are the same.
Input
The first line is the number of test cases, t. 0<=t<=20
The next t lines are test cases containing two numbers, M and N. 1<=M, N<=10.
Output
Output the numbers of method in each test case in one line.
Sample Input
1
7 3
Sample Output

8

代码:

#include<stdio.h>
#include<stdlib.h>
int fu(int m,int n){
if(m==0||n==1)return 1;
if(m<n) return fu(m,m);
else return fu(m-n,n)+fu(m,n-1);}
int main(){
int m,n;
int t;
scanf("%d",&t);
while(t>0){
	scanf("%d %d",&m,&n);
	printf("%d\n",fu(m,n));
t--;}
return 0;}


你可能感兴趣的:(POJ1664放苹果)