题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2602
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2
31).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
状态转移方程为:dp[i]=max(dp[i], dp[i-v[j]]+w[j]);
代码如下:
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int main(){
int v[1001],w[1001],dp[1001],t;
scanf("%d",&t);
while(t--){
int p,n;
memset(dp,0,sizeof(dp));
scanf("%d%d", &n, &p);
for(int i=0; i<n; ++i){
scanf("%d",&w[i]);
}
for(int i=0; i<n; ++i){
scanf("%d",&v[i]);
}
for(int j=0; j<n; ++j){
for(int i=p; i>=v[j]; --i){//dp[i]表示将前j件物品放进容量为i的背包中的最大总价值
dp[i]=max(dp[i], dp[i-v[j]]+w[j]);
}
}
printf("%d\n",dp[p]);
}
return 0;
}