Let the Balloon Rise(STL的map)

Link:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=2104


ZOJ Problem Set - 2104
Let the Balloon Rise Time Limit: 2 Seconds       Memory Limit: 65536 KB

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.


Input

Input contains multiple test cases. Each test case starts with a number N (0 < N < 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.


Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.


Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0


Sample Output

red
pink


Author:  WU, Jiazhi
Source:  Zhejiang Provincial Programming Contest 2004
#include<iostream>
#include<algorithm>
#include<map>
#include<cstdio>
#include<cstring>
#include<sstream>
using namespace std;
map<string,int>ball;
map<string,int>::iterator loc,maxpos;
int main()
{
	int n,max;
	string color;
	while(~scanf("%d",&n)&&n)
	{
	//	if(n==0)
	//	break;
	    ball.clear();//注意每次都要清空,否则会wrong answer!!! 
		while(n--)
		{
			cin>>color;
			ball[color]++;
		}
	    max=0;
	for(loc=ball.begin();loc!=ball.end();loc++)
	{
		if(max<loc->second)
		{
			maxpos=loc;
			max=(*loc).second;
		}
	}
	//cout<<(*maxpos).first<<endl;
	cout<<maxpos->first<<endl;//注意“.”与“->”的用法差别!!!否则会报错。迭代器本身就是指针地址,可直接用“->”
	// 或加“*”取其值后用点“.”访问对应的数据。 
   }
   return 0;
}



你可能感兴趣的:(算法,map,ACM,STL)