Light oj--1008

Description

Fibsieve had a fantabulous (yes, it's an actual word) birthday party this year. He had so many gifts that he was actually thinking of not having a party next year.

Among these gifts there was an N x N glass chessboard that had a light in each of its cells. When the board was turned on a distinct cell would light up every second, and then go dark.

The cells would light up in the sequence shown in the diagram. Each cell is marked with the second in which it would light up.

(The numbers in the grids stand for the time when the corresponding cell lights up)

In the first second the light at cell (1, 1) would be on. And in the 5th second the cell (3, 1) would be on. Now, Fibsieve is trying to predict which cell will light up at a certain time (given in seconds). Assume that N is large enough.

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case will contain an integer S (1 ≤ S ≤ 1015) which stands for the time.

Output

For each case you have to print the case number and two numbers (x, y), the column and the row number.

Sample Input

3

8

20

25

Sample Output

Case 1: 2 3

Case 2: 5 4

Case 3: 1 5


解体思路:这是一道简单的规律题,方格中的数按蛇形进行填充.首先我们观察对角线上的元素发现,设某对角线上元素m,其坐标为(n,n),那么m=n*n-(n-1).接着可以观察到,如果n为奇数,那么与m颜色一样的数的坐标的变化规律为(n,1)......(n,n)...........(1,n);元素的数值由大到小。当n为偶数时,,那么与m颜色一样的数的坐标的变化规律为(1,n)...(n,n).....(n,1);元素的数值由小到大。所以接下来我们所要做到就是:确定与元素s颜色一样的元素中,对角线元素所在的行/列-〉求出对角线元素-〉比较对角线元素与s的大小从而确定s的坐标。而n=[sqpt(s)],即不小于sqrt(s)的最小整数。


代码如下:

#include<stdio.h>
#include<cmath>
int main(){
	int t,k;
	k=1;
	long long s,d,n;
	double m;
	scanf("%d",&t);
	while(t--){
		scanf("%lld",&s);
		m=sqrt(s);
        n=(long long)m;
        if(m>n)n=n+1;
        d=n*n-(n-1);
        printf("Case %d: ",k++);
        if(n%2){//奇 
        	if(s<d){
        		printf("%lld %lld\n",n,n-d+s);
        	}
        		else{
        			printf("%lld %lld\n",n-s+d,n);
        		}
        }
        else{
        		if(s>d){
        		printf("%lld %lld\n",n,n-s+d);
        	}
        		else{
        			printf("%lld %lld\n",n-d+s,n);
        		}
        }
	}
	return 0;
}


你可能感兴趣的:(Light oj--1008)