HDU 1061 Rightmost Digit (快速幂)

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 45761    Accepted Submission(s): 17230


Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the rightmost digit of N^N.
 

Sample Input
   
   
   
   
2 3 4
 

Sample Output
   
   
   
   
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:   1021  1008  1019  1071  1108 
HDU 1061 Rightmost Digit (快速幂)_第1张图片
快速幂求解

<pre name="code" class="cpp">#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int mod(int a,int b,int c)
{
	int res,t;
	res=1%c;
	t=a%c;
	while(b)
	{
		if(b%2)
		{
			res=res*t%c;
		}
		t=t*t%c;
		b=b/2;
	}
	return res;
}
int main()
{
	int T,n,num;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		num=mod(n,n,10);
		printf("%d\n",num);
	}
	return 0;
}
 


 
 

你可能感兴趣的:(HDU 1061 Rightmost Digit (快速幂))