poj3461Oulipo

Oulipo
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 30629   Accepted: 12305

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

Source

BAPC 2006 Qualification
/*KMP算法求次数,多加一步,
*if(j==m){
*    j=next[j];
*    num++;
*}
*/
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <cmath>
#include <ctime>
#include <vector>
#include <cstdio>
#include <cctype>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
#define INF 10050
#define inf -0x3f3f3f3f
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define mem0(a) memset(a,0,sizeof(a))
#define mem1(a) memset(a,-1,sizeof(a))
#define mem(a, b) memset(a, b, sizeof(a))
using namespace std;
int Next[10100];
char pattern[10100],s[1001000];

void get_next(int len){
    int i=0,j=-1;
    Next[0]=-1;
    while(i<len){
        if(j==-1||pattern[i]==pattern[j]){
            i++;
            j++;
            Next[i]=j;
        }
        else
            j=Next[j];
    }
}

void KMP(){
    int len=strlen(s);
    int i=0,j=0,num=0;
    int m=strlen(pattern);
    while(i!=len){
        if(j==-1||s[i]==pattern[j]){
            i++;
            j++;
        }
        else
            j=Next[j];
        if(j==m){
            j=Next[j];
            num++;
        }
    }
    printf("%d\n",num);
}

int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%s",pattern);
        scanf("%s",s);
        int n=strlen(pattern);
        get_next(n);
        KMP();
    }
    return 0;
}


你可能感兴趣的:(poj3461Oulipo)