HDU 1678 Shopaholic(优先队列 + 排序 + 英文-我想哭)

E - Shopaholic
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu
Submit  Status

Description

Lindsay is a shopaholic. Whenever there is a discount of the kind where you can buy three items and only pay for two, she goes completely mad and feels a need to buy all items in the store. You have given up on curing her for this disease, but try to limit its effect on her wallet.

You have realized that the stores coming with these offers are quite selective when it comes to which items you get for free; it is always the cheapest ones. As an example, when your friend comes to the counter with seven items, costing 400, 350, 300, 250, 200, 150, and 100 dollars, she will have to pay 1500 dollars. In this case she got a discount of 250 dollars. You realize that if she goes to the counter three times, she might get a bigger discount. E.g. if she goes with the items that costs 400, 300 and 250, she will get a discount of 250 the first round. The next round she brings the item that costs 150 giving no extra discount, but the third round she takes the last items that costs 350, 200 and 100 giving a discount of an additional 100 dollars, adding up to a total discount of 350.

Your job is to find the maximum discount Lindsay can get.

Input

The first line of input gives the number of test scenarios, 1 <= t <= 20. Each scenario consists of two lines of input. The first gives the number of items Lindsay is buying, 1 <= n <= 20000. The next line gives the prices of these items, 1 <= pi <= 20000.

Output

For each scenario, output one line giving the maximum discount Lindsay can get by selectively choosing which items she brings to the counter at the same time.

Sample Input

1
6
400 100 200 350 300 250

Sample Output

400


这道题目,只要看懂题目就可以了,题目意思是选择三个商品就有一个是免费的,但是免费的必须是三个商品中最便宜的,所以对3的倍数进行从大到小取值就可以了。
这道题可以用优先队列做,也可以直接排序做,此处提供排序

#include <cstdio>
#include <iostream>
#include <string>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
const int MAXN = 20000 + 5;
int T, n;
int p[MAXN];
int main(){
    scanf("%d", &T);
    while(T --){
        scanf("%d", &n);
        for(int i = 0;i < n;i ++){
             scanf("%d", &p[i]);
        }
        sort(p, p + n, greater<int>());
        int res = 0, i;
        for(i = 2;i < n;i += 3){
            res += p[i];
        }
        printf("%d\n", res);
    }
    return 0;
}


你可能感兴趣的:(HDU 1678 Shopaholic(优先队列 + 排序 + 英文-我想哭))