12th.浙江省省赛A题 Ace of Aces

Ace of Aces Time Limit: 2 Seconds      Memory Limit: 65536 KB

There is a mysterious organization called Time-Space Administrative Bureau (TSAB) in the deep universe that we humans have not discovered yet. This year, the TSAB decided to elect an outstanding member from its elite troops. The elected guy will be honored with the title of "Ace of Aces".

After voting, the TSAB received N valid tickets. On each ticket, there is a number Ai denoting the ID of a candidate. The candidate with the most tickets nominated will be elected as the "Ace of Aces". If there are two or more candidates have the same number of nominations, no one will win.

Please write program to help TSAB determine who will be the "Ace of Aces".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <=1000). The next line contains N integers Ai (1<= Ai <= 1000).

Output

For each test case, output the ID of the candidate who will be honored with "Ace of Aces". If no one win the election, output "Nobody" (without quotes) instead.

Sample Input

3
5
2 2 2 1 1
5
1 1 2 2 3
1
998

Sample Output

2
Nobody
998
题意:水 .。 求出现频率最高的数 如果出现两个相同频率的数 输出NobodA
#include <bits/stdc++.h>
using namespace std;
int num[2000];
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        memset(num,0,sizeof(num));
        int n;
        cin>>n;
        while(n--)
        {
            int a;
            cin>>a;
            num[a]++;
        }
        int flag=1;
        int res=0;
        int ans=0;
        for(int i=1; i<=1000; i++)
        {
            if(num[i]>res)
            {
                res=num[i];
                ans=i;
                flag=0;
            }
            else if(num[i]==res)
                flag=1;
        }
        if(flag==1)
            cout<<"Nobody"<<endl;
        else
            cout<<ans<<endl;
    }
    return 0;
}

 

你可能感兴趣的:(12th.浙江省省赛A题 Ace of Aces)