hdu1085Holding Bin-Laden Captive!(母函数)

Holding Bin-Laden Captive!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19565    Accepted Submission(s): 8698


Problem Description
We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China! 
“Oh, God! How terrible! ”

hdu1085Holding Bin-Laden Captive!(母函数)_第1张图片

Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up! 
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!
 

Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.
 

Output
Output the minimum positive value that one cannot pay with given coins, one line for one case.
 

Sample Input
   
   
   
   
1 1 3 0 0 0
 

Sample Output
   
   
   
   
4
 

Author
lcy
 

Recommend

We have carefully selected several similar problems for you:  2082 2079 2110 1059 2566 

个人理解题意:

给你1 2 5硬币的数量让你让你求不能支付的最小值

#include <iostream>
using namespace std;
#include<stdlib.h>
#include<stdio.h>
#include <cstring>
#include<string>
#include<cmath>
#include<algorithm>
int c1[10000],c2[10000];
int main()
{
    int a,b,c;
    while(~scanf("%d%d%d",&a,&b,&c))
    {
        if(a==0&&b==0&&c==0)
            return 0;
        int i,sum,j,k;
        sum=a+b*2+c*5;//求出总质量
        memset(c1,0,sizeof(c1));
        for(i=0;i<=a;i++)
            c1[i]=1;
        memset(c2,0,sizeof(c2));
        for(j=0;j<=a;j++)
         {
            for(k=0;k<=b*2;k+=2)
                c2[j+k]=1;
        }
        for(j=0;j<=sum;j++)
        {
                 c1[j]=c2[j];
                 c2[j]=0;
        }//算出依2为钱币兑换。
         for(j=0;j<=sum;j++)
         {
             if(c1[j]==1)
              {
                for(k=0;k<=c*5;k+=5)
                   c2[j+k]=1;
            }
        }
        for(j=0;j<=sum;j++)
        {
                 c1[j]=c2[j];
                 c2[j]=0;
        }//依5为兑换钱币
        for(i=1;;i++)
         if(c1[i]==0)//找出最小的
          {
              printf("%d\n",i);
              break;
          }
    }
    return 0;
}

你可能感兴趣的:(母函数)