HDU Dancing Stars on Me

Dancing Stars on Me
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 17 Accepted Submission(s): 14


Problem Description
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.


Input
The first line contains a integer T indicating the total number of test cases. Each test case begins with an integer n, denoting the number of stars in the sky. Following n lines, each contains 2 integers xi,yi, describe the coordinates of n stars.

1≤T≤300
3≤n≤100
−10000≤xi,yi≤10000
All coordinates are distinct.


Output
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).


Sample Input
3
3
0 0
1 1
1 0
4
0 0
0 1
1 0
1 1
5
0 0
0 1
0 2
2 2
2 0


Sample Output
NO
YES

NO

#include<stdio.h>
#include<math.h>
typedef struct node{
    double x,y;
}node;
double fun(node a,node b)
{
     double squre;
   squre=sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
   return squre;
}
int main()
{
    int T;
    node a[102],sum;
    scanf("%d",&T);
    while (T--)
    {
        int n,i,flag=1;
        scanf("%d",&n);
        sum.x=0;
        sum.y=0;
        for (i=1;i<=n;i++)
        {
            scanf("%lf %lf",&a[i].x,&a[i].y);
            sum.x+=a[i].x;
            sum.y+=a[i].y;
        }
            sum.x/=n;
            sum.y/=n;
            for (i=2;i<=n;i++)
                if (fun(sum,a[i])!=fun(sum,a[1]))
                    {
                       printf("NO\n");
                       flag=0;
                       break;
                    }
                    if (flag)
                  printf("YES\n");
    }

    return 0;
}
方法总结:判断一些坐标是否能组成正多边形,可以先求出中点的坐标,然后比较中点与各个点之间的距离

你可能感兴趣的:(HDU Dancing Stars on Me)