HDU 4961 Boring Sum

题目链接:Boring Sum


题面:

Boring Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1152    Accepted Submission(s): 543


Problem Description
Number theory is interesting, while this problem is boring.

Here is the problem. Given an integer sequence a 1, a 2, …, a n, let S(i) = {j|1<=j<i, and a j is a multiple of a i}. If S(i) is not empty, let f(i) be the maximum integer in S(i); otherwise, f(i) = i. Now we define bi as a f(i). Similarly, let T(i) = {j|i<j<=n, and a j is a multiple of a i}. If T(i) is not empty, let g(i) be the minimum integer in T(i); otherwise, g(i) = i. Now we define c i as a g(i). The boring sum of this sequence is defined as b 1 * c 1 + b 2 * c 2 + … + b n * c n.

Given an integer sequence, your task is to calculate its boring sum.
 

Input
The input contains multiple test cases.

Each case consists of two lines. The first line contains an integer n (1<=n<=100000). The second line contains n integers a 1, a 2, …, a n (1<= a i<=100000).

The input is terminated by n = 0.
 

Output
Output the answer in a line.
 

Sample Input
   
   
   
   
5 1 4 2 3 9 0
 

Sample Output
   
   
   
   
136
Hint
In the sample, b1=1, c1=4, b2=4, c2=4, b3=4, c3=2, b4=3, c4=9, b5=9, c5=9, so b1 * c1 + b2 * c2 + … + b5 * c5 = 136.
 

Author
SYSU
 

Source
2014 Multi-University Training Contest 9
 
题意:构造b,c两个数列,分别是离每个下标,最近的左右两个为该下标对应值倍数的下标对应的a数列中的值,若不存在,即为该位置对应的a的值。


解题:直接暴肯定不行。先预处理一下,将每个ai的值存在对应下标中。然后,寻找某个值时,只需遍历该值的倍数对应的vector寻找最接近的左边值和右边值。需注意的是当ai比较小的时候就直接寻找,以提高效率,这里边界设置为300。


代码:

#include <iostream>
#include <vector>
#include <cstdio>
#include <cstring>
using namespace std;
int a[100000+10];
vector <int> store[100000+10];
int main()
{
	int n,tmp,maxx,b,c,p,maa,mii;
	bool fla1,fla2;
	long long sum=0,bb,cc;
	
	while(scanf("%d",&n)&&n)
	{
	  maxx=sum=0;
	  for(int i=1;i<=n;i++)
	  {
  		 scanf("%d",&a[i]);
  		 if(a[i]>maxx)
  		   maxx=a[i];
  	  }	
  	  for(int i=0;i<=maxx;i++)
  	     store[i].clear();
      for(int i=1;i<=n;i++)
        store[a[i]].push_back(i);
      for(int i=1;i<=n;i++)
      {
      	fla1=false;
      	fla2=false;
      	if(a[i]<=300)
      	{
	      for(int j=i-1;j>=1;j--)
		  {
  			 if(a[j]%a[i]==0)
  			 {
 			   	p=j;
 			   	fla1=true;
 			   	break;
		     }
  		  }
		  if(fla1)
		  {
  			b=a[p];
  		  }	
  		  else b=a[i];
  		  for(int j=i+1;j<=n;j++)
		  {
  			 if(a[j]%a[i]==0)
  			 {
 			   	p=j;
 			   	fla2=true;
 			   	break;
		     }
  		  }
		  if(fla2)
		  {
  			c=a[p];
  		  }	
  		  else c=a[i];
  		  //cout<<"c"<<i<<": "<<c<<" b"<<i<<": "<<b<<endl;
  		  bb=b;
  		  cc=c;
  		  sum+=bb*cc;
        }
        else
        {
        	maa=100005;
        	mii=-1;
        	tmp=a[i];
        	while(tmp<=maxx)
        	{
	          int si=store[tmp].size();
			  for(int k=0;k<si;k++)
			  {
  				if(store[tmp][k]>i)
  				{
				  if(store[tmp][k]<maa)
				  maa=store[tmp][k]; 	
			    }
			    else if(store[tmp][k]<i)
			    {
    				if(store[tmp][k]>mii)
    				mii=store[tmp][k];
    			}
  			  }	
  			  tmp+=a[i];
	        }
	        if(mii!=-1)
	        {
        		b=a[mii];
        	}
        	else b=a[i];
	        if(maa!=100005)
	        {
        		c=a[maa];
        	}
        	else c=a[i];
        	//cout<<"c"<<i<<": "<<c<<" b"<<i<<": "<<b<<endl;
        	bb=b;
  		    cc=c;
  		    sum+=bb*cc;
        }
      }
      cout<<sum<<endl;
	}
	return 0;
}


你可能感兴趣的:(入门,思维,HDU)