HDOJ 1096 A+B for Input-Output Practice (VIII)(水题)

A+B for Input-Output Practice (VIII)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 114595    Accepted Submission(s): 35170


Problem Description
Your task is to calculate the sum of some integers.
 

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
 

Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
 

Sample Input
   
   
   
   
3 4 1 2 3 4 5 1 2 3 4 5 3 1 2 3
 

Sample Output
   
   
   
   
10 15 6
 

Author
lcy
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   2001  2003  2000  2006  2005
#include<stdio.h>
int main(){
	int n,m,a,sum;
	scanf("%d",&n);
	while(n--){
		scanf("%d",&m);
		sum=0;
		while(m--){
			scanf("%d",&a);
			sum+=a;
		}
		printf("%d\n",sum);
		if(n) printf("\n"); //格式
	}
	return 0;
}


 

你可能感兴趣的:(hdoj)