UVA 846 (暑假-数学 -G - Steps)

 Steps 

One steps through integer points of the straight line. The length of a step must be nonnegative and can be by one bigger than, equal to, or by one smaller than the length of the previous step.

What is the minimum number of steps in order to get from x toy? The length of the first and the last step must be 1.

Input and Output 

Input consists of a line containing n, the number of test cases. Fore
 
 
ach test case, a line follows with two integers: 0xy < 231.For each test case, print a line giving the minimum number of steps toget from x to y.

Sample Input 

3
45 48
45 49
45 50

Sample Output 

3
3
4
 
#include <cstdio>

int main() {
	int t;
	scanf("%d", &t);
	while (t--) {
		int a, b;
		scanf("%d%d", &a, &b);
		int step = 1;
		while (1) {
			if (a >= b) {
				printf("%d\n", 2 * (step - 1));
				break;
			}
			else if(b - a <= step) {
				printf("%d\n", 2 * (step - 1) + 1);
				break;
			}
			else
				a += step, b -= step, step++;
		}
	}
	return 0;
}


你可能感兴趣的:(UVA 846 (暑假-数学 -G - Steps))