poj2553 Longest Ordered Subsequence

poj2553
Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 13831   Accepted: 5864

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1, a2, ..., aN) be any sequence ( ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4
思路:本题是求的最长上升子序列,这里用DP,状态转移方程为:
for 0->i to N-1
LIS[i]=1;
LIS[K]=MAX{LIS[i]:0<=i<k&&a[k]>a[i]}+1
代码:

#include<iostream>
using namespace std;
int a[1010];
int LIS[1010];
int main()
{
    int N,i,j,max;
scanf("%d",&N);
for(i=0;i<N;i++)
{
    scanf("%d",&a[i]);
}
LIS[0]=1;
for(i=0;i<N;i++)
{
    LIS[i]=1;
    for(j=0;j<=i;j++)
    {
        if(a[i]>a[j]&&LIS[j]+1>LIS[i])
            LIS[i]=LIS[j]+1;
    }
}
max=0;
for(i=0;i<N;i++)
{
if(LIS[i]>max)
max=LIS[i];
}
printf("%d/n",max);

    return 0;
}

你可能感兴趣的:(poj2553 Longest Ordered Subsequence)