南邮 OJ 1151 Find Your Present

Find Your Present

时间限制(普通/Java) :  1000 MS/ 3000 MS          运行内存限制 : 32768 KByte
总提交 : 276            测试通过 : 48 

比赛描述

In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.

输入

The input file will consist of several cases. 
Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.

输出

For each case, output an integer in a line, which is the card number of your present.

样例输入

5
1 1 3 2 2
3
1 2 1
0

样例输出

3
2

提示

use scanf to avoid Time Limit Exceeded

题目来源

HDU OJ



#include<iostream>
int main(){
	int n,r,a;
	while(scanf("%d",&n)==1 && n){
		r = 0;
		while(n--){
			scanf("%d",&a);
			r ^= a;
		}
		printf("%d\n",r);
	}
}






你可能感兴趣的:(ACM,find,Your,present,南邮OJ)