Pat(Advanced Level)Practice--1058(A+B in Hogwarts)

Pat1058代码

题目描述:

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28

AC代码:
#include<cstdio>

using namespace std;

int main(int argc,char *argv[])
{
	long long GA,GB,SA,SB,KA,KB;
	long long Gans,Sans,Kans;
	int temp;
	scanf("%lld.%lld.%lld %lld.%lld.%lld",&GA,&SA,&KA,&GB,&SB,&KB);
	temp=(KA+KB)/29;
	Kans=(KA+KB)%29;
	Sans=(SA+SB+temp)%17;
	temp=(SA+SB+temp)/17;
	Gans=temp+GA+GB;
	printf("%lld.%lld.%lld\n",Gans,Sans,Kans);

	return 0;
}


你可能感兴趣的:(C++,pat,基础题,advance)