UVA - 140 Bandwidth(全排列枚举)

 Bandwidth 

Given a graph (V,E) where V is a set of nodes and E is a set of arcs in VxV, and an ordering on the elements in V, then the bandwidth of a node v is defined as the maximum distance in the ordering between v and any node to which it is connected in the graph. The bandwidth of the ordering is then defined as the maximum of the individual bandwidths. For example, consider the following graph:

This can be ordered in many ways, two of which are illustrated below:

For these orderings, the bandwidths of the nodes (in order) are 6, 6, 1, 4, 1, 1, 6, 6 giving an ordering bandwidth of 6, and 5, 3, 1, 4, 3, 5, 1, 4 giving an ordering bandwidth of 5.

Write a program that will find the ordering of a graph that minimises the bandwidth.

Input

Input will consist of a series of graphs. Each graph will appear on a line by itself. The entire file will be terminated by a line consisting of a single #. For each graph, the input will consist of a series of records separated by `;'. Each record will consist of a node name (a single upper case character in the the range `A' to `Z'), followed by a `:' and at least one of its neighbours. The graph will contain no more than 8 nodes.

Output

Output will consist of one line for each graph, listing the ordering of the nodes followed by an arrow (->) and the bandwidth for that ordering. All items must be separated from their neighbours by exactly one space. If more than one ordering produces the same bandwidth, then choose the smallest in lexicographic ordering, that is the one that would appear first in an alphabetic listing.

Sample input

A:FB;B:GC;D:GC;F:AGH;E:HD
#

Sample output

A B C F G D H E -> 3


题目大意:
给定一个图(V,E),其中V为顶点的集合,E为边的集合,属于VxV。给定V中元素的一种排序,那么顶点v的带宽定义如下:在当前给定的排序中,与v距离最远的且与v有边相连的顶点与v的距离。给定排序的带宽定义为各顶点带宽的最大值。写一个程序,找出该图的一种排序使其带宽最小。


解析:直接用全排列枚举出所有的可能,分别计算带宽,然后选取最小的一种方案。

#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;
const int INF = 0x3f3f3f3f;
const int N = 30;
int edge[N][N];
bool vis[N];
int arr[N];
int n;

void init(char str[]) {
	memset(edge,0,sizeof(edge));
	memset(vis,0,sizeof(vis));
	int u,v;
	int len = strlen(str);
	for(int i = 0; i < len;) {
		if(str[i] >= 'A' && str[i] <= 'Z') {
			u = str[i] - 'A';
			vis[u] = true;
			i++;
		}else if(str[i] == ':') {
			while(str[i] != ';' && str[i] != '\0') {
				if( str[i] >= 'A' && str[i] <= 'Z') {
					v= str[i] - 'A';
					vis[v] = true;
					edge[u][v] = edge[v][u] = 1;
				}
				i++;
			}
			i++;
		}
	}
	n = 0; //保存节点个数
	for(int i = 0; i < N; i++) {
		if( vis[i]) {
			arr[n++] = i;
		}
	}
}

int solve() {
	int u,v;
	int d,maxd,Max;
	Max = -INF;
	for(int i = 0; i < n; i++) {
		u = arr[i];
		maxd = -INF;
		for(int j = i+1; j < n; j++) {
			v = arr[j];
			if(edge[u][v]) {
				d = j - i;	
			}
			maxd = max(d,maxd);
		}
		Max = max(Max,maxd);
	}
	return Max;
}
int main() {
	char str[N];
	char tmp[N];
	while(scanf("%s",str) != EOF) {
		if( str[0] == '#') {
			break;
		}
		init(str);
		sort(arr,arr+n);
		
		int Min = INF,sum;
		do{
			sum = solve();
			if( Min > sum) {
				Min = sum;
				for(int i = 0; i < n; i++) {
					tmp[i] = arr[i] + 'A';
				}
			}
		}while(next_permutation(arr,arr+n));
		for(int i = 0; i < n; i++) {
			printf("%c ",tmp[i]);
		}
		printf("-> %d\n",Min);
	}
	return 0;
}

你可能感兴趣的:(uva,bandwidth)