Pat(Advanced Level)Practice--1068(Find More Coins)

Pat1068代码

题目描述:

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 104 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=104, the total number of coins) and M(<=102, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the face values V1 <= V2 <= ... <= Vk such that V1 + V2 + ... + Vk = M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output "No Solution" instead.

Note: sequence {A[1], A[2], ...} is said to be "smaller" than sequence {B[1], B[2], ...} if there exists k >= 1 such that A[i]=B[i] for all i < k, and A[k] < B[k].

Sample Input 1:
8 9
5 9 8 7 2 3 4 1
Sample Output 1:
1 3 5
Sample Input 2:
4 8
7 2 4 3
Sample Output 2:
No Solution

AC代码:
一个变形的背包问题:背包问题要求背包里物品的总价值最大,这里要求总数为一个给定的值。
动态规划方程:dp[i][j]=max{dp[i-1][j],dp[i-1][j-coin[i]]+coin[i]},其中dp[i][j]表示前i个硬币所能组成的最大数为j。
#include<cstdio>
#include<cstdlib>
#include<functional>
#include<algorithm>
#define N 10005
#define M 105

using namespace std;
int dp[N][M],flag[N][M];
int coin[N];

int main(int argc,char *argv[])
{
	int i,j;
	int n,m;
	scanf("%d%d",&n,&m);
	for(i=1;i<=n;i++)
		scanf("%d",&coin[i]);
	sort(coin+1,coin+1+n,greater<int>());
	for(i=1;i<=n;i++)
	{
		for(j=coin[i];j<=m;j++)
		{
			if(dp[i-1][j]<=dp[i-1][j-coin[i]]+coin[i])
			{
				dp[i][j]=dp[i-1][j-coin[i]]+coin[i];
				flag[i][j]=1;
			}
			else
				dp[i][j]=dp[i-1][j];
		}
	}
	if(dp[n][m]!=m)
		printf("No Solution");
	else
	{
		int first=1;
		for(int i=n;i>=1&&m>0;i--)
		{
			if(flag[i][m])
			{
				if(first)
				{
					printf("%d",coin[i]);
					first=0;
				}
				else
					printf(" %d",coin[i]);
				m-=coin[i];
			}
		}
	}
	printf("\n");

	return 0;
}


你可能感兴趣的:(C++,dp,pat,基础题,advance)