Can you find it?
Time Limit: 10000/3000 MS (Java/Others) Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 10424 Accepted Submission(s): 2742
Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
Sample Output
第一次二分,,尼玛刚开始写的很挫啊,,不过现在还好。。
#include<cstdio>
#include<algorithm>
using namespace std;
int a[505],b[505],c[505],f[250010];
int binary(int x,int M,int k)
{
for(int i=0; i<M; i++)
{
int l = 0, r = k;
while(l <= r)
{
int mid = (l+r)/2;
if(x > c[i]+f[mid]) l = mid+1;
else if(x < c[i]+f[mid]) r = mid-1;
else return 1;
}
}
return 0;
}
int main()
{
int L,N,M,i,j,s,t=1;
while(~scanf("%d%d%d", &L,&N,&M))
{
for(i=0; i<L; i++)
scanf("%d", a+i);
for(i=0; i<N; i++)
scanf("%d", b+i);
for(i=0; i<M; i++)
scanf("%d", c+i);
int k = 0;
for(i=0; i<L; i++)
for(j=0; j<N; j++)
f[k++] = a[i]+b[j];
sort(f,f+k);
scanf("%d", &s);
printf("Case %d:\n", t++);
while(s--)
{
int x;
scanf("%d", &x);
printf(binary(x,M,k-1) ? "YES\n" : "NO\n");
}
}
return 0;
}